トップ 差分 一覧 Farm ソース 検索 ヘルプ RSS ログイン

BBS-サポート掲示板/975

ページの作成や編集にはユーザ登録が必要です。

 Software Errorについて - ひろぽん (2013年06月18日 15時18分01秒)

先日、IISにて運営している、自作サーバーに設置させて頂いたのですが、どうもページ作成時にエラーが出るようです。

設置した当日は、正常に動作しておりましたが、次の日編集しようとアクセスしましたが、特定のページにアクセスできず、新規ページも作成できない状態です。

エラーの内容はこちらですSoftware Error:

Can't call method "config" on an undefined value at lib/Wiki/DefaultStorage.pm line 401.

wiki本体のデータが、破損したのかと思い、データをダウンロードしてきたものと入れ替えましたが解決しませんでした。

プラグインは、tag2プラグインを導入しています。

IISバージョンは7.0OSはWindows server 2008R2アクティブパールは5.14.4wikiバージョンは3.6.4です。詳しい方、よろしくお願いします。

  • ご無沙汰してます。tag2プラグインの作者です。IISと聞いただけで身の毛もよだちます。(>_<) さすがにそろそろ安定してるんでしょうか? 余談はさておき、上記不具合ですが、dataディレクトリは作成されてますか? おそらくまだ設置したばかりですよね? ドキュメント通りの設置が難しいようでしたらFSWiki初期設置用CGIをお試しください。 - あき (2013年06月19日 22時19分42秒)
  • 設置した当日は動作していた? はて??? ごめんなさい。想像つきません。orz - あき (2013年06月19日 22時22分40秒)
  • コメントありがとうございます。 - ひろぽん (2013年06月21日 18時12分50秒)
  • えーとですね、IISの方は結構安定してますね!不具合の方ですが、dataディレクトリも作成済みです。作成が必要なものはすべて作成したはずなんですけどね・・・。設置した日は、正常に動作していたのですが朝起きて、再度接続を試みるとエラー。という感じですね。 - ひろぽん (2013年06月21日 18時15分40秒)
  • ありゃ、お返事頂けてたんですね。気が付くのが遅くなってごめんなさい。うーん、でも設置した当日は動いてて次の日は動かないって…。ん?ログインができないとかですか? - あき (2013年06月23日 20時43分27秒)
  • ログインはできるんですよね。しかし、ページの作成・特定のページの閲覧ができない状態となっております。見れるページと見れないページがあるためもう何が何だか・・・。ページの構成が複雑になってくると見れないのかもしれません。タイトル:テスト 本文:テスト このような感じでページを作成した際には正常に作成もされページを見ることも可能でした。一度、IISの再構成とwikiプログラムの完全な入れ直しを試してみますね。 - ひろぽん (2013年06月24日 17時55分38秒)
  • IISのせいにしたいわけじゃないですけど、IISの不安定さっていうのはまさにそういう所だったんですよねぇ。何か知らないけどキャッシュが効いてしまってるっぽい動きとか、同じはずなのにあっちは動いてこっちは動かないとか、そういった類。再起動させると正常に動作するようになったり、それでも動かないままだったり…。なのに何かの拍子でまた動き始めたり…。今回の件もまさにそれらと同じような気がしてならないのですが…。 - あき (2013年06月26日 02時56分48秒)
  • 書き込み遅くなり申し訳ないです。多忙と、サーバー構築に時間がかかってしまい、書き込みが遅くなってしまいました。どうせなら、新OSにアップデートしよう。ということでWindows server 2012へのアップデートを実行しましたがIISの設定時にどうもうまくCGIを動作させることができずに、別のWebサーバーソフト(Abyss Web Server)にてCGIプログラムのみを動作させることになりました。こちらに変えてから、今まで起きていたエラーが全く出なくなりましたので、IISの問題が濃厚かもしれません。この度は、お手数をおかけして申し訳ありませんでした。 - ひろぽん (2013年07月25日 02時21分06秒)
  • 同じエラーが出たので、コメントします。このエラーはpagelist.cacheに関係があるようです。エラー前のpagelist.cacheに戻したら症状が改善しました。 - なす (2014年03月24日 13時56分13秒)
  • 追加です。ページ内の文言に、Wiki内に存在するページの名称(FrontPage)などが含まれていると、このエラーに陥ります。 - なす (2014年03月24日 14時00分49秒)
  • 当方にてIIS環境を構築して検証してみましたが、特に同様のエラーは発生しておりません。エラー発生するようになる前の作業ではどのような操作を行っていたでしょうか?なすさんの懸念されているように pagelist.cache が関係しているかもしれませんが、ひとつの考慮事項としては、FTP等でバックアップ目的でファイルを定期的に転送するような運用時にシステム文字コードでコード変換されてしまっている・・・という状況はないでしょうか?また、ページ作成はゲストでも発生しますか?ログインユーザーの場合だけ発生する場合は、cookie や Wiki内で使用しているセッションファイルなどが疑われると思います。 - KG (2014年03月24日 15時57分29秒)
  • 以前の情報ですが、この件は「ページの自動リンク」の設定を「自動でリンクしない」に設定したところエラーが出なくなりました。文字コードの問題のようにもみえますが、はっきりとはわかりません。 - なす (2014年04月23日 10時50分16秒)
お名前: コメント:

最終更新時間:2014年04月23日 10時50分16秒