トップ 差分 一覧 ソース 検索 ヘルプ RSS ログイン

BugTrack-wiki/129

ページの作成や編集にはユーザ登録が必要です。

3.5.1dev4 refがエラーに

  • 投稿者: Mya
  • カテゴリ: 本体
  • 優先度: 重要
  • 状態: リリース済
  • 日時: 2003年09月30日 02時16分17秒

 内容

3.5.1. dev4をインストールして出てきたエラーです。

dev3等でチェックしてなかったのでdev4個有か分かりません。

PDFファイルを ref プラグインで参照したページを見に行くと次のエラーが出ます。

Software error:

Can't locate object method "config" via package "xxx.pdf" (perhaps you forgot to load "xxx.pdf"?) at lib/Util.pm line 185.

原因がよく分からないので、バグ投稿のみです。よろしくおねがいいたします。

 コメント

  • plugin/attach/Ref.pmに以下のパッチで解消すると思います。 - たけぞう (2003年09月30日 11時27分24秒)
46c46
<        my $mime = &plugin::attach::AttachHandler::get_mime_type($file);
---
>        my $mime = &plugin::attach::AttachHandler::get_mime_type($wiki,$file);
  • $mimeは特に使用していない変数なので、Ref.pmの46行目をコメントアウトでいいですね。 - たけぞう (2003年09月30日 15時59分44秒)
  • ありがとうございます。動きました。 - Mya (2003年09月30日 23時32分

最終更新時間:2006年01月22日 05時03分15秒