トップ 差分 一覧 ソース 検索 ヘルプ RSS ログイン

BugTrack-plugin/344

ページの作成や編集にはユーザ登録が必要です。

【FSWikiLite】簡易パスワード認証を追加したedit.cgi

  • 投稿者: tak
  • カテゴリ: 新規
  • 優先度: 低
  • 状態: 提案
  • 日時: 2007年05月16日 11時56分58秒

 内容

.htaccessが使えないサーバ等でとりあえず編集にパスワード認証をかけたい時用のedit.cgiです.

このスクリプトを用いることで,編集の度にパスワードを求められるようになります.

パスワードを編集して元のedit.cgiと差し替えるだけで使用できるのでお手軽です.

ソースを見ていただければわかりますがとても簡易的な物で,あくまでもとりあえず用です.BASIC認証や【FSWikiLite】シンプルログインパッチ(BugTrack-plugin/324)など他の手段が使える方はそちらを使うようにしてください.

 インストール

添付ファイルを解凍すると、edit.cgiがでてきます。

必要ならば環境にあわせて1行目

#!/usr/bin/perl

を変更してください。

ソース中のパスワード設定にあるパスワードを任意の文字列に変更してください.

元のedit.cgiと差し替えれば使用できます.

 コメント

お名前: コメント:
edit.zip

最終更新時間:2007年05月16日 12時24分06秒