トップ 差分 一覧 Farm ソース 検索 ヘルプ RSS ログイン

BBS-サポート掲示板/788

ページの作成や編集にはユーザ登録が必要です。

 PDFでSoftware Error - jina (2008年02月03日 17時34分06秒)

初めてFreeStyle Wikiをインストレーションしました。右上のPDFをクリックすると

Software Error:Not a HASH reference at lib/PDFJ.pm line 2841, <DATA> line 320.

のエラーになってしまいます。原因としてどのようなことが考えられますでしょうか。どうぞよろしくお願いいたします。

環境は以下になります。

  • Windows VISTA
  • ActivePerl 5.10.0.1002 c:\usr
  • Apache 2.2.8 c:\usr\Apache2
  • Wiki 3_6_2
  • Setup.cgi rev03
  • pdfディレクトリを作りましたか? - 名無しさん (2008年02月05日 03時46分09秒)
  • コメントありがとうございます。pdfディレクトリはSetup.cgiの実施により作成されています。 - jina (2008年02月05日 06時34分36秒)
  • VISTA環境が原因かと思ってXP環境にもインストレーションしてみましたが同様でした。 - jina (2008年02月10日 23時12分19秒)
  • 具体的な根拠があるわけではないのですが、Perl 5.10 は Perl 5.8 系に対して一部非互換な部分があると聞いています。可能であれば、Perl 5.8 系で試されてはいかがでしょうか? もし、違っていたらゴメンナサイですが...。 - むめい (2008年02月11日 01時33分28秒)
  • お蔭様で解決しました。ActivePerl5.8.8に変えたらPDFが表示されるようになりました。大変ありがとうございました。 - jina (2008年02月11日 08時18分54秒)
  • 使っているモジュールPDFJ が,Perl 5.9 で廃止されたphash を使っている所為だと思います.PDFJ へのパッチ書きました.ご参考までに http://d.hatena.ne.jp/clairvy/20090227/PDFJ090_with_perl510 - clairvy (2009年03月01日 13時47分25秒)
  • clairvy さんのパッチと同じ手法を用いることにより perl 5.9 以降でも動作する pdf プラグインを BugTrack-plugin/402 にて提案させていただきました。 - ぐうます (2009年06月25日 19時21分35秒)
  • Perl5.26以降対応の為、PDFJ-0.91RC1に変更してコミットしました。あわせて、pdfプラグインの一部を修正して当件の対応とさせていただきます。 - KG (2018年01月15日 19時22分40秒)
お名前: コメント:

最終更新時間:2018年01月15日 19時22分40秒