トップ 差分 一覧 Farm ソース 検索 ヘルプ RSS ログイン

雑談掲示板

ページの作成や編集にはユーザ登録が必要です。

FSWiki雑談掲示板

サポート掲示板は質問などの書き込みが主になっているようなので、FSWikiを使っての感想など、些細なおしゃべり・雑談の場合はこちらをお使いください。話が盛り上がってきたら適宜、サポート掲示板などに話題を移行させるような感じでの使い方もできるかもしれません。

  • 過去ログはページ下部の選択肢から参照できます。
  • 件数が増えてきたら古いものから順に過去ログに移動します。
  • 雑談掲示板一覧もどうぞ。
  • 設置に関するトラブルや要望などはサポート掲示板のほうにお願いします。
  • バグ報告に関してはバグトラックのほうにお願いします。
  • FSWikiとは無関係と思われる投稿、コメントに関しては削除させていただきますのでご了承ください。
お名前
件名
本文

別名URLアンカーを使うとURLが2重になります。 - sumari (2008年01月21日 14時46分54秒)

別名URLアンカー(別名)の様に書くとURLが、http://hostname.com/hoge/hostname.com/hoge/Testの様になりvateプラグインなどが動かなくて困っています。設定の問題だと思うのですが、どこを治していいかわかりません。

同じような現象が発生した方いらっしゃいましたら、対応方法などおしえてもらえないでしょうか?

  • wikiのページ名へのリンクは
[[別名|Test]]

のように、かっこを二重にします。外部のページへのリンクは

[別名|http://www.betsumei.com]

のように、かっこが一重です。ここらへんを混同されているのでは。- 名無しさん (2008年01月21日 16時16分36秒)

  • 正確には、voteプラグインを使うと上記の様な現象が発生します。
[別名|wiki.cgi]

と書くと、http://hostname.com/hoge/hostname.com/hoge/wiki.cgiとなってしまいます。これが原因でvoteプラグインがうまく動かなくなってしまうのです。- sumari

  • voteプラグインがどうこうというのはよくわかりませんが、最初に書きましたとおり、例えばこうかけばいいんじゃないですか? 別名
[別名|http://example.org/wiki.cgi]

- 名無しさん (2008年01月22日 07時13分12秒)

  • ええとわかにくくてすみません。

voteプラグインを利用しようとして

{{vote 質問,選択1,選択2}}

と書くと投票ボタンのリンクがhttp://hostname.com/hoge/hostname.com/hoge/wiki.cgi?...となってしまい、投票ができないのですよ。

それで原因を調べてたら、voteプラグインは内部的に

[投票|wiki.cgi?...]

と出力していることがソースコードからわかったんです。

それで

[別名|Test]

と私のWikiに書いてみたところ、http://hostname.com/hoge/hostname.com/hoge/Testと出ることを確認しました。

次にこのWikiのSandBoxで

 [別名|Test]

と入力するときちんと http://hostname.com/hoge/Testと出力されるのでなんでかな?っと思ったわけですよ。

  • ここまでわかっているのなら、Vote.pmの該当行を、
$buf .= ",$item,$count票 - [投票|http://hostname.com/hoge/".$wiki->config('script_name').

と書き換えればいいのでは。 - 名無しさん (2008年01月22日 17時24分45秒)

  • これ、vote プラグインのバグですよね。理由はどうあれ、変なwiki書式でごまかしてるからこういうことがおこるわけで。きちんとHTMLでform書くべきでは。 - 名無しさん (2008年01月22日 17時30分34秒)
  • fswiki 3.6.3 では $wiki->create_url(...) を使用するように修正されていますので、この問題は解決すると思います。 - KG (2008年01月22日 17時39分05秒)
  • 本当にvoteプラグインのバグですか?

まず、URLが2重に出てしまうのは、

[別名|Test]

と記述した場合、setup.datのserver_hostにhostname.comと打っているとhostname.com/hoge/が2重に出てしまうことが原因だとわかりました。

これが仕様なのかバグなのかは私にはわかりません。

次になんとなくですが、

[別名|Test]

と打ったら、urlは、http://www.hostname.com/hoge/wiki.cgi?Testと出るのが感覚的にあっているのですが、違うのでしょうか?

- sumari (2008年01月22日 19時39分46秒)

  • URLが二重になっちゃうということ自体は、voteプラグインのバグではないと思います。でも、KGさんが書かれているように、 Vote.pmの中で、$wiki->create_urlを使うべきなのに使ってないと言う意味で、vote プラグインにバグがあると思います。で、このバグは次バージョンで修正されている、と。 - 名無しさん (2008年01月22日 19時52分02秒)
  • また、wikiのページ名を別名でリンクにするときは
[[別名|Test]]

とかっこを二重に書きます。かっこを一重に書くのは、以下のように、

[別名|http://example.org/wiki.cgi]

URLを別名のリンクにする場合です。かっこが一重のときにページ名を書くのはwiki書式として変なのではないでしょうか。その意味で、次バージョンの修正で正しく動作するとはいえ、vote プラグインには、まだ変なところが残ってんじゃないかな、と思います。私としては、変なwiki書式でごまかすのではなく、HTMLでform書くのが感覚的にあっていますが、違いますかね。 - 名無しさん (2008年01月22日 19時53分34秒)

  • 1重の括弧の話は、私が2重括弧と間違えていました。ごめんなさい。 - sumari (2008年01月22日 20時09分55秒)
お名前: コメント:

スパム書き込みのようですので、削除をお願いします。 - ALC (2008年01月20日 08時23分56秒)

テーマ投稿のページにスパム書き込み(BugTrack-theme/23)がありましたので、お手数ですが削除をお願い致します。

  • このよう書き込みを行うのではなく、気がついた人が勝手に消しちゃっていいと思います(というか消しました)。 - 名無しさん (2008年01月20日 10時31分48秒)
お名前: コメント:

naviviewプラグインでPagetreeページを削除したところwikifarmが読み込めず - まこと (2008年01月14日 15時03分41秒)

お世話になっています。まことと申します。

naviviewプラグインなるものを見つけ、早速インストールして動作確認をしておりましたが。

テスト用のPagetreeページが不要になったため削除したところ。

「Modification of non-creatable array value attempted, subscript -1 at plugin/naviview/Naviview.pm line 298.」と表示され、そのfarmでは一切なにもできなくなってしまいました。

おそらくは「naviview Pagetree,v,o,e」がMenuに組み込まれている状態でPagetreeを削除したためnaviviewプラグインがエラーで終了しているものと思いますが。以下条件によりFarm削除し一から作り直す以外、お手上げ状態です。

・Apacheのプロセスアカウントはnobody

・与えられているアカウントはnobody以外

・rootのパスワードは開示してもらえない

・与えられているアカウントにてプラグイン設置は可能であった

そのFarmではいろいろページを作成しておりできるだけ一から作成しなおすことは避けたい状況です。よって現在の使用できないFarmのMenuページのnaviviewプラグインが動作している以上何もできません。以下対応が考えられます。

・naviviewプラグインをOS側操作によって無効にする

 -> plugin/naviviewディレクトリの削除で可能?(親Farmへの影響が出そうで怖く試すことが出来ていませんが・・・)

・対象FarmのMenuページをOS側操作によって削除

 -> 与えられているアカウントでの削除は不可でした。

・Pagetreeページをbackup/<FARMディレクトリ>より復活させる

 -> ディレクトリへの書き込み権限がないため不可でした。

上記状況の中でどなたか復活させることができた方法があればご教示ください。また、perlの知識はないですがnaviviewプラグインのここを直せば、存在しないpagetreeページを指定している場合でもFarmの表示はこけない等を教えていただけると助かります。

以上、よろしくお願いいたします。

  • 雑談掲示板に書くのではなく、naviview プラグインのページのコメント欄に書いた方が回答を得られると思いますよ。 - 名無しさん (2008年01月14日 19時08分57秒)
  • 了解しました。naviview プラグインのページへ移動しました - まこと (2008年01月14日 21時53分01秒)
お名前: コメント:

本サイト既存ページにおけるサイト内リンクの旧 URL での絶対パス指定の件 - ぐうます (2008年01月04日 20時54分02秒)

本サイトを「ページ内容も含める」をチェックした上で旧 URL "http://fswiki.poi.jp/wiki.cgi?" で検索すると明らかなように、サイト内リンクとして旧 URL で絶対パス指定されている箇所がかなりあるようです。1 つづつ手編集で直すと大変なので、*.wiki に対し一括置換をしていただくことはできますでしょうか? ご検討のほど、よろしくお願い致します。

お名前: コメント:

空行を入れたい - かわ (2007年12月31日 13時18分03秒)

3行空行を入れるにはどうすれば?

上に改行3つ入れた。が勝手に狭まるよね。HTMLプラグインとか入れずに簡単にできたらいいなぁ。ウェブサイトを面白く魅せるために結構必要じゃない??

  • ってか、標準では任意の位置で改行(空行ではなく改行)することすらできませんよね? 私自身はかわさんの考えに同感ですが、そういった表現は見栄えに関するものでありHTMLの規格(考え方、方針)に反するそうです。よって標準実装は今後も期待できないでしょう。いろんな形での表現方法を様々なプラグインにて実装していますので、それらで代用してください。議論の最中(闘病中にて最近何もできておりません)でまだ完成系ではありませんが、個人的には拡張Wiki記法プラグインがプラグインっぽくなく利用できる、という点でオススメです。 - あき (2008年01月01日 03時49分46秒)
  • 標準の実装でも管理画面の環境設定で改行をBR要素(強制改行の表現)に変えることも出来ます。こちらを利用する(質問の意図する表現を実現できませんでした)。もしくは、BRを挿入するプラグインを連続で記述するというのは如何でしょうか(HTMLの文法としては間違いですが、編集者が最も手軽に実現できるのも確かです)。「一見して画面には表示されないのだけど、スクロールしてゆくとサプライズな表現があった」など確かにオモシロイ表現のために利用するケースは多いと思います - A_M (2008年01月01日 08時19分13秒)

同プラグインで次のように記述すると、HTML文法にも沿った形で1行目の下部分(2行目との行間)を 3em分だけ開けることが出来ます。

{{div_begin style=margin-bottom:3em;}}
1行目
{{div_end}}
2行目

(A_M 追記)

  • A_M殿、ナイスです。それなら文法的にも問題ありませんね。 - あき (2008年01月01日 09時48分03秒)
  • あきさん、A_Mさん,お正月からご返信ありがとうございます! - かわ (2008年01月01日 12時12分23秒)
  • HTMLを全く知らない私の妻がブログとしてWikiを利用し始めたので、なるべく簡単な方法を探していました。文法としては間違っててもBRを連続して使う方法で利用させていただこうと思います。ここら辺の敷居が下がればWikiがもっと初心者の人に広まるのにな〜>そういう意味では拡張Wiki記法プラグインは素晴らしいですね!可能ならWYSIWYG編集が出来れば最高。 - かわ (2008年01月01日 12時21分15秒)
  • 管理画面の環境設定で改行の処理を「BRタグに変換する」に変更するという方法ではダメでしょうか? - たけぞう (2008年01月01日 22時29分02秒)
  • 改行の処理を「BRタグに変換する」に設定しても複数の改行が連続してあった場合には1つのBRタグになってしまいますが、これは複数の改行になるように変更してもよいかもしれませんね。 - たけぞう (2008年01月01日 22時37分06秒)
  • たけぞうさん、ありがとうございます!その変更はすごく嬉しいです。早速直したいのですが、どこを修正すればよいですか?HTMLParser? - かわ (2008年01月02日 13時01分25秒)
  • HTMLParser.pmに以下のような修正を行えばそれっぽく表示されるようになると思います。 - たけぞう (2008年01月02日 17時58分57秒)
226a227,228
> 	} elsif($self->{wiki}->config('br_mode')==1){
> 		$self->{html} .= "<br>\n";
  • 3.6.2では223行目ですね。ありがとうございました。 - かわ (2008年01月02日 22時48分31秒)
お名前: コメント:

子Wikiにも親Wikiの設定を反映したい - CAN (2007年12月22日 18時23分23秒)

はじめまして。早速の質問失礼します。親Wikiの管理ページでの設定(プラグインのON/OFF等)を即座に子Wikiに反映させる方法またはプラグインをどなたかご存じないでしょうか?親Wikiと子Wikiを別々に設定しなくてはならず大変なのでお力をお貸ししていただけると幸いです。分かりにくい文章になりすみません。

  • この機能は実装されていませんね。CANさんの仰るように、ルートWikiで全Farmのプラグイン管理を行えると便利だと思います。 - A_M (2007年12月24日 13時41分27秒)
  • そうですか。分かりました。A_Mさんどうもありがとうございました。では、今のところは現状どおり別々に設定をするようにします。 - CAN (2007年12月24日 18時04分31秒)
お名前: コメント:

Picasaウェブアルバムの画像を貼りたい - 名無しさん (2007年12月05日 18時00分49秒)

要望掲示板に書くほどの内容でもないかと思うのでここに書かせてもらいます。Picasaウェブアルバムの画像へのリンクを貼りたいのですが、htmlタグをそのまま書いてもリンクは貼れないですよね。あちこちのページに多数貼りたいのでinclude_htmlプラグインでは面倒なので、もっと簡単に貼れるプラグインをどなたか作っていただけるとうれしいのですが。

  • 『Picasaウェブアルバム』自体がよく分らないのですが(単に勉強不足なだけです。すみません)、画像へのリンクを貼りたいだけでしたら、装飾用HTMLタグプラグインのa_imgで実現できないでしょうか? - あき (2007年12月14日 23時42分40秒)
  • サービス名だけでなくどういうタグなのかも書けばよかったですね。すみません。Picasaウェブアルバムの画像へのリンクはサムネイル画像を表示して、ウェブアルバムの元画像へのリンクが貼られる物です。 - 名無しさん (2007年12月17日 10時26分37秒)
お名前: コメント:

ログインしたときにだけ表示されるメニュー - 名無しさん (2007年11月17日 01時08分14秒)

サイドメニューで、通常は表示されないけれども、ログインしたときにだけ表示されるようなメニューの作成方法はどうすればいいのでしょうか?

いままでは一覧から選んでいたんですが、ページが増えると下のほうに行くので時間がかかり、現在はIEのお気に入り登録している始末です・・・

もっとスマートな方法はないものでしょうか?

  • すみません、自己解決しました!! こちらに今回の件とは直接関係はありませんが「・・・参照権限のないページを見せない部分入れて・・・」という記載があり、もしや?!と思って、categoryプラグインでMenuを作成し、表示したくないページだけ管理者権限にしたら、望みどおりの結果になりました。 - 名無しさん (2007年11月17日 01時19分01秒)
  • categoryでリスト表示させるときには、それを表示しているユーザー権限に依存するんですね。知りませんでした・・・。 - 名無しさん (2007年11月17日 01時22分33秒)
  • BugTrack-theme/20に書いたレイアウト・プラグインとそのテンプレート(のonly_logon ログイン時のみ表示)を使った方法の方が、スマートな気がします。categoryでのリスト表示がユーザー権限に依存する、というのは、偶然を利用しているっぽい感じでスマートではないかも…。本人の自由ですが…。 - あき (2007年11月17日 08時09分38秒)
お名前: コメント:

ドキュメントが見れない - 名無しさん (2007年11月11日 02時43分03秒)

Lock is busy. at plugin/core/ShowPage.pm line 68. at lib/Util.pm line 684.

ドキュメントを見ようとすると上記のエラーが表示されて見れません。私だけでしょうか?

  • BBS-サポート掲示板/575に書かれている対処法は? - 名無しさん (2007年11月11日 11時21分16秒)
  • 公式サイトのドキュメントのWikiが参照できないということですよね。公式サイトをmod_perlからCGIに変更して動かしているのですが、その影響のようです。しばらくお待ちください。 - たけぞう (2007年11月11日 21時52分31秒)
  • たけぞうさん 言葉足らずですみません。その通りです。また当方でも正常に見れるようになった事をご連絡致します。ご対応有難うございました。以上 - 名無しさん (2007年11月13日 14時03分58秒)
  • 一時的にmod_perlからCGIに変更しています.とありまして、私も通常のperlに変更しようとしていますが、上記エラーが出て困っています。どこをどのように直したら、通常のperlで動くようになりますでしょうか。。 - ゆう (2008年04月09日 16時29分44秒)
  • たけぞう様しかわからなそうですね。。 尚、今まで動いていたので、パーミッション等は間違いありません。 mod_perl の環境下であれば、正常動作します。 - ゆう (2008年04月10日 08時53分22秒)
  • mod_perlに関するバグが何点か表面化しているため,一時的にmod_perlからCGIに変更しています. この時の変更手順について、誰かわかる方がいらっしゃったらコメントお願いします。 因みに、wiki.cgi はいじっていません。。 - ゆう (2008年04月10日 11時07分22秒)
  • 普通に考えたらApacheの設定でしょ? - 名無しさん (2008年04月11日 05時01分16秒)
  • Apache は、通常の CGI は動作し、mod_perl の部分は、削除しています。 - ゆう (2008年04月11日 09時27分29秒)
  • Apacheの設定 じゃありませんでした。書き込みするログファイルの所有者の問題でしたね。 どうもありがとうございました。 - ゆう (2008年04月11日 10時02分06秒)
お名前: コメント:

レンタルサーバー上のdataフォルダ内のファイルがダウンロード出来ない - 名無しさん (2007年11月04日 13時30分46秒)

dataフォルダ内の%のついたエンコードされたファイルがダウンロード出来ないのです。サーバーは http://2nd.cssv.jp/ のレンタルサーバーになります。FTPツールはFFFTP 1.92aを使っています。他のサーバーではエンコードされたファイルも問題無いようです。確認ポイントについてどなたか教えていただけないでしょうか。

  • FTPサーバに問題があるのではないでしょうか,サーバ屋に問い合わせたほうが早いと思います. - sakuma (2007年11月05日 07時37分35秒)
  • サーバ屋に問い合わせしたところ、あっけなく解決しました。セキュリティ対策で禁止してましたがftpdのバージョンアップで対応したことから禁止解除したとのことでした。こんなこともあるんですね・・・ - 名無しさん (2007年11月12日 23時18分16秒)
お名前: コメント:

[ 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 ]

最終更新時間:2014年08月28日 09時33分14秒